Jump to content
TGGRRR (Ali)

Tigger is broken, oil light on

Recommended Posts

Wahhhhhhh I took Tigger out for a fun day on Friday and as I was almost home everytime I stopped the oil light would go on. Then as soon as I was moving it would go out.

 

I got him home and later checked the oil, it was a little low. Mark topped it off but said it wasn't even a full quart low. Then he drove him again and as soon as he was warm the light came on.

 

I called PTuning, they said don't drive him and bring him in. Soooo I'm waiting for AAA now to get him. PTuning thinks it might be the oil pressure pump, I hope it's not anything serious

Tigger 2006 the cabrio and Riversong the 2014 Countryman

Tggrrr010.jpg

Link to comment
Share on other sites

53 minutes ago, TATTRAT said:

Hopefully an easy fix, Ali! I know the gang down at PTuning will get you sorted.

Thanks Jono

 

From what I googled this shouldn't be too bad. They're really busy so I'm patient.

Tigger 2006 the cabrio and Riversong the 2014 Countryman

Tggrrr010.jpg

Link to comment
Share on other sites

4 hours ago, TGGRRR (Ali) said:

Thanks Jono

 

From what I googled this shouldn't be too bad. They're really busy so I'm patient.

Oil pump shouldn't be to bad, hope he's back up and running soon.

  • Like 1

1975Mini001.jpg

1975 Mini 1000, 998cc A+ w/ K&N air filter, 10" Mamba wheels

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...